Please Notice: For fastest support from PowerArchiver team, contact us via our Support page

PA2009 B1 & B2: No Shell Extensions



  • I used PA2007 until yesterday. Till that that day I had Shell Extensions for PA. After installing 2009 B1 there were no Shell Extensions. I changed the Shell Extension Options in the PA Config, but still there are no Shell Extensions.

    Today I installed PA2009 B2 and still there are no Shell Extensions… After right clicking on a file there are no options to use PA2009. 😞

    What can I do? Is this a bug? Only my bug?

    I’m using Windows Vista Home Premium x64.



  • there are some problems with the 64 bit version of vista, i would recommend you go to 32 bit version of vista if you can.

    failing that wait for an update.

    microsoft were stupid in the fact that 32 shell extensions are not fully compatible with 64 bit shell extensions thats why at the moment shell extensions does not work well on 64 bit version of vista.

    all i can say is thanks for reporting it but it will take time in the mean time hope everything else works ok



  • I have the same problem. I use the shell extensions very often and it would be very uncomfortable, when the final version would not fully support Viste x64.
    Perhaps than I have to switch to another program.


  • conexware

    did you guys reboot your computer after installation?

    PA 2007 support 64bit shell extension, PA 2009 should be the same, unless some bug sneaked in.



  • @davidsplash:

    there are some problems with the 64 bit version of vista, i would recommend you go to 32 bit version of vista if you can.

    I don’t have problems with other programs. So why I should go back to x86?? 😕

    @davidsplash:

    microsoft were stupid in the fact that 32 shell extensions are not fully compatible with 64 bit shell extensions thats why at the moment shell extensions does not work well on 64 bit version of vista.

    But why shell extensions work with PA2007? I used PA2007 untill yesterday and also on x64…

    @davidsplash:

    all i can say is thanks for reporting it but it will take time in the mean time hope everything else works ok

    No problem. If I find another bug, I will report too. 😉

    @spwolf:

    did you guys reboot your computer after installation?

    Yes, I did. But it didn’t work. Further I cleaned up my registry with TuneUp Utilities after deinstalling PA2009. I also removed all things from PA in my registry manually. Tried to install again and hoped for a change, but no change…

    @spwolf:

    PA 2007 support 64bit shell extension, PA 2009 should be the same, unless some bug sneaked in.

    I hope, that you can find this bug. 🙂


  • conexware

    can some other people check if it works for them? We had some x64 alpha testers… thanks



  • Yes, it works for me (on Vista x64 Ultimate)



  • But why it doesn’t work for me? 😞

    I only removed PA2007 and installed PA2009. What could be the problem?



  • I have also the problem with PA2009 Beta 2 an Vista Ultimate 64-Bit!

    No Shell Extensions!!:mad:


  • conexware

    we will figure it out and let you know.



  • @spwolf:

    we will figure it out and let you know.

    That would be great! 🙂



  • I am also running am running Beta 2 of 2009 Pro on Vista x64 Home Premium. Good news, I have shell extensions. The bad news is they just don’t work. If I have file on the desktop and use ‘Extract Here’ a PA window will appear quickly but not do anything and disappear. If I extract to the folder as the same name of the archive, it does the same thing, but creates a folder which is empty. Everything was working fine in 2007.

    Ok, I just discovered something. If I right click it in place with no drag. It works fine. If I drag it a little, it does the stuff I described above. I even tried moving the file off the desktop and no luck.


  • conexware

    @cipher:

    I am also running am running Beta 2 of 2009 Pro on Vista x64 Home Premium. Good news, I have shell extensions. The bad news is they just don’t work. If I have file on the desktop and use ‘Extract Here’ a PA window will appear quickly but not do anything and disappear. If I extract to the folder as the same name of the archive, it does the same thing, but creates a folder which is empty. Everything was working fine in 2007.

    Ok, I just discovered something. If I right click it in place with no drag. It works fine. If I drag it a little, it does the stuff I described above. I even tried moving the file off the desktop and no luck.

    so it doesnt work with drag and dropping the archive and using right click? But it works if you just right click?





  • But you have the shell extensions and it works for you, if you just rightclick the archive. I don’t have the shell extensions… 😞


  • conexware

    @PoooMukkel:

    I used PA2007 until yesterday. Till that that day I had Shell Extensions for PA. After installing 2009 B1 there were no Shell Extensions. I changed the Shell Extension Options in the PA Config, but still there are no Shell Extensions.

    Today I installed PA2009 B2 and still there are no Shell Extensions… After right clicking on a file there are no options to use PA2009. 😞

    What can I do? Is this a bug? Only my bug?

    I’m using Windows Vista Home Premium x64.

    just to confirm - are you using english or german?



  • German PA2009 on German Vista x64


  • conexware

    so to clarify - it doesnt work in german PA, works in English (with some issues)…. quick fix is to uninstall german and install english.

    Both issues will be fixed in Beta 3 (english and german).

    thanks



  • I have a similar problem with PA2009 B1 or B2:

    when i drag an archive to another folder by using the right mouse button, both options “extract here” and “extract to subfolder” just create an empty folder without any files inside.
    I’m using “german vista x64 sp1” with latest “english PA2009”.



  • ^^That’s the same problem Cipher has posted already some answers ago… 😉

    @spwolf
    I’ll wait for the Beta 3. 🙂


Log in to reply
 

Looks like your connection to PowerArchiver Forums was lost, please wait while we try to reconnect.