Plugin's



  • i have version 10.21.17 and have downloaded the MSI plugin however its file extension is .ppf and when i go to instal a plugin its looking for extension .wcx will the above plugin work or do i need to rename the extension.


  • conexware

    just doubleclick on .ppf file in windows explorer and PA will ask to install it.



  • @spwolf:

    just doubleclick on .ppf file in windows explorer and PA will ask to install it.

    Sorry, Spwolf, but .ppf files are not associated with PA (at least on my system) and I can’t find this extension in Options > Configuration > File Formats…

    So after double clicking that file, please select the PowerArchiver from the list (or provide the path to POWERARC.EXE, by default - C:\Program Files\PowerArchiver\POWERARC.EXE) and click OK
    Then PA will ask to install…

    Thanks,


  • conexware

    @NTFS:

    Sorry, Spwolf, but .ppf files are not associated with PA (at least on my system) and I can’t find this extension in Options > Configuration > File Formats…

    So after double clicking that file, please select the PowerArchiver from the list (or provide the path to POWERARC.EXE, by default - C:\Program Files\PowerArchiver\POWERARC.EXE) and click OK
    Then PA will ask to install…

    Thanks,

    thats an bug then… you can also open it inside of PA via Open button and it will ask for installation…

    thanks.



  • How do I know the plugin installed? There’s nothing in the plugin folder.



  • @guido:

    How do I know the plugin installed? There’s nothing in the plugin folder.

    You don’t see the files in Program Files because PA stores them in:
    C:\ProgramData\ConeXware\PowerArchiver\Plugins
    (in Windows Vista)
    (common Application Data folder)

    Vista UAC requirements do not allow writting to Program Files…

    You can see the plugins list and add/remove them in Configuration > Plugins…

    Thanks,

    Serhiy



  • Found it.

    The strange thing is, this plugin is installed in the folder.

    C:\Documents and Settings\All Users\…

    My guess is that everybody gets the plugin instead of only me. Is this wanted behavior?



  • @spwolf:

    thats an bug then…

    It should be fixed then… 🙂



  • @guido:

    Found it.

    The strange thing is, this plugin is installed in the folder.

    C:\Documents and Settings\All Users\…

    My guess is that everybody gets the plugin instead of only me. Is this wanted behavior?

    As I wrote, PA stores them in Common Application Data folder. And from there they are avaiable TO THE ALL WINDOWS ACCOUNTS.
    You are using Windows NT/2000 or XP…
    so it is in C:\Documents and Settings\All Users…
    In vista it is
    in C:\ProgramData…

    And it is normal behavior because it allows to install Plugins without Administrator permissions



  • One more thing. If I install a ppf by double clicking it, it looks like it is installed by a admin account instead of Current User.



  • @NTFS:

    As I wrote, PA stores them in Common Application Data folder. And from there they are avaiable TO THE ALL WINDOWS ACCOUNTS.
    You are using Windows NT/2000 or XP…
    so it is in C:\Documents and Settings\All Users…
    In vista it is
    in C:\ProgramData…

    And it is normal behavior because it allows to install Plugins without Administrator permissions

    It could also install it for my account only. The files would be placed in C:\Documents and Settings\Guido\… I can access this folder also. And remove it without admin permission.

    My question was if installing the it for all users is wanted behavior. I would at least expect a question if I want to install the plugin for myself or for all users.

    I it’s for all users I guess C:\Documents and Settings\All Users… is fine. If it’s for myself only, I would expect the files to be in

    C:\Documents and Settings\Guido…



  • @guido:

    One more thing. If I install a ppf by double clicking it, it looks like it is installed by a admin account instead of Current User.

    Did you receive UAC elevation prompts in vista? If you did that in WinXP then how do you know that it requires Admin rights?



  • @guido:

    It could also install it for my account only. The files would be placed in C:\Documents and Settings\Guido\… I can access this folder also. And remove it without admin permission.

    C:\Documents and Settings\Guido
    is “User Application Data” folder avaiable only to specific Windows Account and unaccesible to others (except Administrator’s , of course)

    @guido:

    …My question was if installing the it for all users is wanted behavior. I would at least expect a question if I want to install the plugin for myself or for all users…

    Ok, this Prompt can be added in the future version…



  • It’s in XP. The thing is. After install, PA is opened. This installation is not registered.

    Second point. If I close PA and reopen PA and look for my plugins in the configuration it’s empty.

    I have open PA and from the main window I have to open the ppf file to install it. If I don’t do this, the plugin does not get installed.



  • @guido:

    It’s in XP. The thing is. After install, PA is opened. This installation is not registered.

    Second point. If I close PA and reopen PA and look for my plugins in the configuration it’s empty.

    I have open PA and from the main window I have to open the ppf file to install it. If I don’t do this, the plugin does not get installed.

    It is because PA doesn’t seem to check if there any plugins in the folder. It looks up the Windows Registry in:
    HKEY_CURERNT_USER\Software\PowerArchiver\Plugins
    for them…
    And when you install the plugin it writes it’s path to the registry…

    Look! it uses HKEY_CURERNT_USER this means that plugins will be visible as “Installed” only for the current windows account.

    I think it wold be better instead of storing this information in registry just scan the Plugins folder for them…



  • BTW, storing this data to the registry privents the For-All-Users installation without admin permissions…


  • conexware

    Will have to think about the answers :-).



  • well i have vista UAC turned off and i opened the files by selecting open archive, change file type to *.ppf then install it and it appears to be working.

    thanks for your help guys



  • @jamieewart:

    well i have vista UAC turned off and i opened the files by selecting open archive, change file type to *.ppf then install it and it appears to be working.

    thanks for your help guys

    Actually you don’t have to disable UAC to do this. Just open the file as standard user. I don’t recommend disabling security features such as UAC at all. If some application requires disabling UAC to work properly then it’s its developers’ problem.


 

Suggested Topics

4
Online

9.8k
Users

6.0k
Topics

36.6k
Posts

Copyright © 1998-2018 ConeXware, Inc.
All rights reserved. Privacy Policy