Crash at Exit with PA 10.2 Beta 2



  • PA 10.20.02 on XP x64

    Open PA with an empty archive, close PA, boom

    First-chance exception at 0x0049890f in POWERARC.EXE: 0xC0000005: Access violation reading location 0x1a000008.
    according to VS 2005



  • I run windows XP Pro SP2 with the latest updates as of 2 weeks ago and installed the same PA Version but did not experience this issue??

    Did you do an upgrade or a clean install??

    try uninstalling the program, then delete the PowerArchiver Folder in Program Files. Reboot and re-install then to be safe restart again!

    If it still happens then send an error report to PowerArchiver Support.



  • @Vykranth:

    Open PA with an empty archive, close PA, boom

    What is an empty archive ?
    What archive format?



  • My mistake on the empty archive: it’s open PA without an archive loaded.

    It was a clean install after a uninstallation of PA 10.2 Beta 1.

    I already tried the reinstall/reboot Sir Richard suggested. Same problem.



  • How odd?

    If not already try this then (only if you know the registry)

    1. Uninstall PowerArchiver 2006/07
    2. Delete “Program Files/PowerArchiver” Folder
    3. Delete Registry Link

    HKEY_CURRENT_USER\Software\PowerArchiver\

    then… if you have any registry cleaning software such as CCleaner or tune-up etc… do a full registry clean!

    Restart then re-install…

    If it still continues then it must be a fault with the program or something on your system is causing a conflict.



  • Tried the procedure but that did not help
    However, I have more information:
    the crash occurs only with the classic skin, not with the ribbon interface.
    The Default blue skin works nicely.
    I though it may have been Windowblinds causing the problem. I unloaded Windowblinds and run PA: with the Windows classic style, PA does not crash, with the Windows XP style, PA crashes.

    That’s really odd.



  • Well, I have PowerArchiver :: Classic

    Windows XP - Appearance XP Style / Color Silver

    But no crash.
    If you can reproduce it, provide/attach a DR Watson Log File (Zip).



  • Did I read the original post correct that you are using the 64bit version of XP or is it the 32?

    I’m not able to reproduce, but I’m using the 32 bit, so maybe it is a 64 bit problem.



  • I think I reproduced the error… it ocured when I did the following

    1. Open PA With Silver Default Ribbon
    2. Change to Blue Default Ribbon
    3. Change to silver default Ribbon
    4. Change to classic
    5. Change to Silver default

    (I couldnt replicate it all the time only when I was clicking and changing skins like a mad man)

    the errors are as follow’s (does it look familer?)


    attachment_p_12342_1_pa-error.jpg
    attachment_p_12342_0_3b11_appcompat.txt



  • Yes, I am using XP x64. The errors reported by Sir Richard looks similar.



  • PA,

    I will forward those results via your support page for you to look at!

    Cheers crew, Vykranth Hopefully, this will support PA to amend the problem ready for the next release!


  • conexware

    those are two different bugs - we are looking at 64bit one, already reported here while i will move sir richs to new thread…

    p.s. devs on vacation until sunday, so expect new release in 6-7 days…thanks!



  • To be fair spywolf this is the 1st error I have personally experienced with PA in a long time!!

    Looking forward to the next release, keep up the good work!


  • conexware

    Please check with Beta 3 preview:
    http://www.powerarchiver.com/test/release10/powarc1020b3.exe

    and let us know if it works properly now.

    thanks!



  • Hiya,

    I don’t have the crash at exit I experienced intially.
    I did have one crash when changing from the classic skin to the modern silver sking but I cannot reproduce it anymore.

    I will try again later to see if I can reproduce it systematically.

    Thank for the early preview. As Sir Richard said, it has been a very long time since I reported a problem in PA.
    Keep up the good work

    Vykranth


 

5
Online

9.8k
Users

6.0k
Topics

36.8k
Posts