Two new bugs to report.



  • When renaming a file in a large archive, if you press ‘enter’ twice, or click ‘ok’ once and then click it again, it will generate an error and sort of crash. Its like it somehow has already started the rename process, yet the controls let you try and start it again, and then it crashes. I say sort of, because the program stays open and the archive stays open, but you get an error message, and the listing of the files in the archive disappears from onscreen. I also say ‘large’ archive, as you only get time to try and click twice if you are dealing with a large archive. If it is a smaller one then the process completes and removes the window before you would have a chance to click a second time (although on slower computers this would probably be just as big a problem on the smaller files). I found this out because I had pressed ‘enter’ and then when it took a bit with the window still sitting there, I thought I must have hit ‘shift’ by accident or that maybe ‘enter’ was not accepted, so I then clicked the ‘Ok’ button, and was greeted with the bug. I then tried doing a similar rename, but just clicking the “Ok” button twice, and it does the same thing.

    The second bug is concerning password entry. If you drag and drop a file onto a open copy of Power Archiver you will get the “Drag and Drop” window. This particular ‘add’ window seems to have a bug in the password entry validation scheme. If you select any of the encryption methods, and then enter a password, but then re-enter it in the second dialog box incorrectly, it goes away without warning you in with a dialog that the passwords don’t match. I found this out because I was trying to add a file to an archive with password protection and accidentally typed the password wrong in the re-type window, and then clicked to add the file to the archive, whereupon I got the warning that I had selected an encryption option yet had not entered a password, as it had correctly discarded the mismatching passwords, but had not warned me. I have tried other methods of invoking the ‘add’ window, and it seems that only the ‘drag and drop’ version of the ‘add’ window has this bug concerning entering non-matching passwords while trying to apply encryption.


  • conexware

    thanks - in the future, please report bugs in separate threads, and name the thread accordingly so we can easily indentify which is which…

    thanks!



  • Sorry about posting both in one thread, I didn’t realize that it would be a problem. If these should be in different threads though, you will have to split them - as I don’t seem to be able to delete or rename a thread I have started. Also, do give feedback once you have examined/fixed the bug. Its nice to be able to track the progress of things and its interesting to find out what the underlying issues were in the first place.


  • conexware

    NP, just for the future…


  • conexware

    thanks!

    The issues should be fixed in 10.1.


  • conexware

    Please check prerelease version 10.1 B1:
    http://www.powerarchiver.com/test/alpha100/powarc1010b1.exe

    And let us know if this fixes your issue.

    thank you!



  • Well, I can happily report that both bugs are fixed in that latest build that you left a link to. Sorry for taking so long to notice your post! Anyhow, both bugs are properly squashed, and that is good! However, now I have noticed something else odd about the rename dialog. It now correctly disables input once you have begun a rename operation, BUT if you are simply changing one character of the existing name, the file won’t get renamed. If I were to try and rename a file called “beta1.exe” to “beta2.exe” it would not rename it. But if I changed more than one character, such as renaming it to “bEta2.exe” then it would work. Anyhow, thanks for fixing the first two bugs, and good luck squashing this last annoyance.


  • conexware

    Thanks!

    The issue should be fixed in Beta 2.


  • conexware

    This should be fixed in latest version:
    http://www.powerarchiver.com/test/release10/powarc1010.exe

    Please let us know…

    thanks!


Locked
 

4
Online

9.8k
Users

6.0k
Topics

36.8k
Posts