Registry Settings

  • Anyone here willing to post the registry settings for the following key:


    I’ve currently got the default value set to:


    And I’m still missing my Compress menus when I right click on objects. It might require me to log off and on so I’ll try that and post back with the results. If anyone knows of a way to force the registry to get re-installed for a particular ID, that would be particularly helpful.


    The forums look swell.

    Jim Carlock

  • Logging off and logging back on did not correct the issue.

    There’s also a problem with the colors in the title bar under the title bar entitled, “Threads in Forum: General”. The blue text color hides the text well and makes great camouflage! The text ends up unreadable!

    Specifically, the unreadable text reads (readability requires highlighting):

    Thread/Thread Starter, Rating, Last Post, Replies, Views.


    Jim Carlock

  • conexware

    Hi Jim,

    did you try uninstalling PA and installing it again? easiest way to reset everything.

    Plus, download latest version from our dl page in any case.


  • The system seems to be case sensitive. The following default value (REG_SZ) works fine and the right-click menus work once again (without a reboot or logoff, but it did take a few minutes for the changes to run their course through the system).


    There’s a way to push the changes through. I just don’t know which API gets called to do it. I’ll run an API monitor to see if I can track down an API call (a registry update occurs when one clicks on Tools, Folder Options… in Explorer, then clicks on the File Types tab and changes a setting there. I’m just not sure if it’s one specific API or if there’s a conglomeration of registry calls).


  • I ran into a little problem with .ZIP files as well. I’m using version 10.00.36. I’ll describe the problem and then how I tried to fix it through Power Archiver, but that failed, then I’ll describe how I fixed it through Windows.

    Here’s possibly the way to duplicate it. Earlier today I had some problems as described at the beginning of this thread. Not many people go around deleting registry keys, but they could perhaps end up with a problem whereby PowerArchiver fails to configure itself properly to open .ZIP files.

    So while trying to correct the previous problem…

    OS: XP SP2
    PowerArchiver Version 10.00.36
    .Net is NOT installed

    Inside an Classic Explorer window…

    1. Click on Tools.
    2. Click on Folder Options…
    3. Click on the File Types tab.
    4. Click on the File Types heading so as to sort by File Types.
    5. Scroll down to the PowerArchiver items, they’ll all be sorted nice and neat.
    6. The Delete button presented itself as a valid option and I deleted all the PowerArchiver types.
    7. Close the Explorer dialogs. They’re useless now, as you can no longer delete anything once this is done.
    8. Open PowerArchiver and reassociate the types via PowerArchiver. This seems like it should restore everything back to properness, but…
    9. Go back into Explorer, Folder Options…, File Types to take a look at the items there. None of them show up as PowerArchiver files any longer.

    In other words, they don’t show up as PowerArchiver Zip file. It’s a Zip file. I think this is an easy fix that’ll provide benefits, but then again there’s no option to restore the file to the original settings, so perhaps there should be a check mark to Set All To PowerArchive File Types.

  • conexware

    are they still associated? When you doubleclick on the zip file, does it open in PA?

    p.s. is there an reason for not rebooting your system, server or something?

  • : are they still associated? When you doubleclick on the zip file, does it open in PA?

    Well, most were associated. The ZIP extension though… maintained the association with the Windows default, meaning when I double-clicked upon a .zip file in Explorer, Explorer opened the file. I could have fixed that by going directly into the registry, but I fixed it instead by clicking upon Tools, Folders Options… then selecting the File Types tab, then scrolling down to the .ZIP extension, and clicking upon the Change button.

    That’s corrected now, but I noticed that many of the File Types listed there do not expose the Delete button any longer when I highlight them. If you can duplicate the problem by deleting the extensions, and confirming the problem that would be helpful to me, and possibly to you, but if can’t duplicate the problem, then there must be something goofy going on with this particular machine and I’ll have to live with it until I figure out what’s going on.

    : p.s. is there an reason for not rebooting your system, server or something?

    Yes, it’s a server, and rebooting doesn’t fix things and it ends up as a waste of time as the boot time takes awhile.

    I took a look at what was going on with Windows Registry API (using Rohitab’s API monitor) and noticed that after changing one of the items via the Change button under the Explorer File Types tab, Explorer then re-reads the keys that were changed.

    The calls work as follows…

    RegCreateKeyExW, “.01\OpenWithProgids”
    RegSetValueExW, “PARAR”
    RegOpenKeyExW, “.01\OpenWithProgids”
    RegCreateKeyExW, hKey:0x80000001, “Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts.01\OpenWithList”
    RegOpenKeyExW, hKey:0x80000000, “.01”

    There’s alot more going on but it appears that after the key gets set, it gets closed, then reopened, then requeried, and there’s a heck of alot of enumerating going on as well, but I believe it’s the fact that after the key is updated, it’s then re-queried.

    I didn’t check what’s going on inside PowerArchiver, I figured you guys already know what’s up there. ;-)

    Jim Carlock

Log in to reply