PA 2007 installs not retaining previous settings



  • All PA 2007 betas I’ve installed clobber the old install. This means I have to both reenter the registration code and reconfigure all my settings. Even now, going from beta 4 to beta 5 required that I once again redo everything.

    I most certainly hope this will be fixed.

    Thanks



  • Totaly agree with you, this has also happend to me on every upgrade and it does become slight frustrating more so when you have to re configuire all your settings over and over again.

    This is why in one of my posts I asked for a “Save Configuiration” button that extracts your prefered settings to a file which you can upload on the next upgrade thus stoping you from having to re apply everything all over again.

    For security reasons you can understand why you need to re-enter your serial number but for beta’s i wouldnt say it was needed. more so on full releases.


  • conexware

    @Sir:

    Totaly agree with you, this has also happend to me on every upgrade and it does become slight frustrating more so when you have to re configuire all your settings over and over again.

    This is why in one of my posts I asked for a “Save Configuiration” button that extracts your prefered settings to a file which you can upload on the next upgrade thus stoping you from having to re apply everything all over again.

    For security reasons you can understand why you need to re-enter your serial number but for beta’s i wouldnt say it was needed. more so on full releases.

    its an bug, so you shouldnt need to re-enter everything every time 🙂



  • Cheers for that! We will let you off :0) this is what you get being beta testers!



  • @welhaux:

    All PA 2007 betas I’ve installed clobber the old install. This means I have to both reenter the registration code and reconfigure all my settings. Even now, going from beta 4 to beta 5 required that I once again redo everything.

    I most certainly hope this will be fixed.

    Thanks

    Still not fixed in Beta 6, I had to enter all my info and redo my configuration again.

    Thanks,
    Normandie



  • I’m also noticing the same problem.


  • conexware

    it has been fixed in beta 6, problem is that it depends on previous installation you did… so in next version it will work fine for you guys…



  • @spwolf:

    it has been fixed in beta 6, problem is that it depends on previous installation you did… so in next version it will work fine for you guys…

    Great, thanks alot & have a good day.

    Normandie



  • Hi

    I have just installed beta 6 of PA 2007, and it asks me to register again (enter my name and code) every time I run it. Is this the same problem as the one you guys have described?

    Just installed it on a new install of XP without upgrading, and I also uninstalled 2007 and installed 2006, entered my details and code, checked it worked ok, then upgraded to 2007 and the same thing happened.

    Is this fixed with the fix for the settings changing, or have I found a new bug?

    Cheers

    Matt


  • conexware

    @DJMatty:

    Hi

    I have just installed beta 6 of PA 2007, and it asks me to register again (enter my name and code) every time I run it. Is this the same problem as the one you guys have described?

    Just installed it on a new install of XP without upgrading, and I also uninstalled 2007 and installed 2006, entered my details and code, checked it worked ok, then upgraded to 2007 and the same thing happened.

    Is this fixed with the fix for the settings changing, or have I found a new bug?

    Cheers

    Matt

    you need to visit your account and get codes for PA 2007, as they are different from PA 2006 codes.

    thanks,



  • Hi spwolf

    Thanks for that, got new codes and it works fine 🙂

    It’s not obvious that new codes was what was wrong when it happens though, can it check and tell the user that they need new codes?

    Matt


  • conexware

    @DJMatty:

    Hi spwolf

    Thanks for that, got new codes and it works fine 🙂

    It’s not obvious that new codes was what was wrong when it happens though, can it check and tell the user that they need new codes?

    Matt

    there is no way for us to do that right now… which is why it is written on the website several times 🙂



  • In beta 7 i have the same problem. I reformated my hard drive and installed beta 6 and then i installed beta 7 and i have to renter my settings again. looks like pa is over writing the settings thats what my installed monitor is saying. When will this be fixed i have a windows 2000 computer. its an annoying part of upgradeing pa with every beta



  • I can confirm this too, all my settings for the previous beta (including the serial number) were lost during the upgrade to the latest beta.

    It would be nice if the installer could remember the settings (shell extensions, folders etc.) during the update.



  • Not fix in 7, still had to enter all the reg info.



  • Confirmed here too with beta 7. It would be nice to export settings just so we wouldn’t have to go through this - but, that’s a different issue. 😉


  • conexware

    @By-Tor:

    Confirmed here too with beta 7. It would be nice to export settings just so we wouldn’t have to go through this - but, that’s a different issue. 😉

    we found another bug… it will be now fixed for… b9 :-).

    thank you guys - you can always export via regedit.exe and then just execute the .reg file after installation…



  • As others have stated, this is definitely NOT FIXED in Beta 7



  • Ditto!

    I have actually designed my own regkey that will upload my Username, Serial aswell as my old prefered settings in order to save time as we are now in Beta 7 and still the settings don’t seem to save after an upgrade.

    In some new software programs when upgrading or uninstalling you have the option to keep or delete your current registry settings I would suggest that this might be an idea PA2008 Have or maybe a later release of 2007 Final.


  • conexware

    @Sir:

    Ditto!

    I have actually designed my own regkey that will upload my Username, Serial aswell as my old prefered settings in order to save time as we are now in Beta 7 and still the settings don’t seem to save after an upgrade.

    In some new software programs when upgrading or uninstalling you have the option to keep or delete your current registry settings I would suggest that this might be an idea PA2008 Have or maybe a later release of 2007 Final.

    again, it is an bug :-). It will still be reset in B8, but then it will work fine in B9 or final, whatever comes sooner :-).



  • this is still not fixed and it means i have to change the toobars and settings every install.



  • Did they release beta 9 and I miss it?


  • conexware

    @amh209:

    Did they release beta 9 and I miss it?

    no, just nobody is reading what I write anymore

    🙂


  • conexware

    try now guys…



  • It worked for me! 😃 😃 😃



  • @spwolf:

    try now guys…

    Thanks spwolf, works for me!!! 😃

    Have a nice day,
    Normandie



  • Fixed in PowerArchiver 2007 10.00.28 Beta 9



  • Just for fun err… testing, I uninstalled PA beta, rebooted, then installed PA 2006 and entered registration code.

    Then I tried “upgrading” to Beta 9…

    Of course, registration is “lost” - but the timer showed
    Days Used : 16 (Out of 30)

    Not sure where this came from, but I like it - two weeks to get the new/free code seems eminently fair.

    Maybe in this specifc case (upgrade of registered version) there should be a text stating that new codes are needed and where to get them?

    Even the skin was preserved when switching to classic view 🆒

    The only other setting not preserved were the shell extensions - not really surprising.


  • conexware

    @TBGBe:

    Just for fun err… testing, I uninstalled PA beta, rebooted, then installed PA 2006 and entered registration code.

    Then I tried “upgrading” to Beta 9…

    Of course, registration is “lost” - but the timer showed
    Days Used : 16 (Out of 30)

    Not sure where this came from, but I like it - two weeks to get the new/free code seems eminently fair.

    Maybe in this specifc case (upgrade of registered version) there should be a text stating that new codes are needed and where to get them?

    Even the skin was preserved when switching to classic view 🆒

    The only other setting not preserved were the shell extensions - not really surprising.

    If you just installed PA 2007, it would be at 0. But uninstalling PA 2007 will not reset it to 0 🙂



  • @spwolf:

    If you just installed PA 2007, it would be at 0. But uninstalling PA 2007 will not reset it to 0 🙂

    As I said I don’t think there is a problem it is just that
    if I uninstall PA 2007 and install PA 2006 it says:
    Days 842 (out of 30) - Expired 😃

    And I was used to seeing that - earlier 2007 BETAs also told me that.

    Now if I uninstall PA 2007(B9) and install PA 2007(B9) it says:
    Days 16 (out of 30)

    That’s why I mentioned it.
    Maybe the 16 days used is just counted from installation of PA 2007 Beta 8 - but as I did enter register code for that I am not sure where it counts from 😕


  • conexware

    @TBGBe:

    As I said I don’t think there is a problem it is just that
    if I uninstall PA 2007 and install PA 2006 it says:
    Days 842 (out of 30) - Expired 😃

    And I was used to seeing that - earlier 2007 BETAs also told me that.

    Now if I uninstall PA 2007(B9) and install PA 2007(B9) it says:
    Days 16 (out of 30)

    That’s why I mentioned it.
    Maybe the 16 days used is just counted from installation of PA 2007 Beta 8 - but as I did enter register code for that I am not sure where it counts from 😕

    We changed the the date for counting PA 2007 in one of the beta’s, so it counts from then… I am not sure exactly which one was it…



  • Well I was just wondering if a first time upgrade from PA2006 to PA2007 will reset the counter to 0 for PA2007?

    There is another “problem” however.
    When upgrading from PA 2006 to PA 2007, the entry in Add/Remove programs for PA 2006 is not removed.
    So I now have two entries.

    If I now click to remove PA 2006 - it actually removes the installed PowerArchiver but leaves the entry for PA 2007 in Add/Remove programs 😕


  • conexware

    You should uninstall PA 2007 and then PA 2006, and then install PA 2007.

    As to the counter, it is relative to when it is installed first on your system, which is why it shows you 16 days… to person who installs it today, it will be 0.

    thanks,



  • @spwolf:

    You should uninstall PA 2007 and then PA 2006, and then install PA 2007.

    So “upgrading” from PA2006 to PA2007 is not going to be possible - only clean install (with loss of settings).


  • conexware

    @TBGBe:

    So “upgrading” from PA2006 to PA2007 is not going to be possible - only clean install (with loss of settings).

    unless you want to leave PA 2006 entry in Control Panel…. If thats fine, then upgrading is possible.



  • fixed in latest beta


Log in to reply
 

  • 4
  • 13
  • 5
  • 8
  • 5
  • 2
  • 9
  • 2