Error when compressing large directories with 7z



  • In the course of compressing large directories (4-6 Gb) with upwards of 10,000 files on maximum settings PowerArchiver Crashes with the following error:

    AppName: powerarc.exe AppVer: 9.6.3.1 ModName: powerarc.exe
    ModVer: 9.6.3.1 Offset: 00001d59

    I am also including the error reporting file from MS.

    The current directory I am zipping is 6.43 Gb with 11,685 files

    This happens at different points in the zipping process, sometimes at 35% or 5% or anywhere inbetween. The 7-Zip program itself has no problem with compressing the directory.

    Please help. If you need any additional information please let me know.
    attachment_t_1657_0_9ac4_appcompat.txt


  • conexware

    can you try replacing 7zip dll from 9.62 with one you have now in 9.63 and see if that works?

    thanks!


  • conexware

    also, can you reboot your computer so you get latest shell extensions please?

    thanks!


  • conexware

    and how much memory do you have? Ultra setting is very memory intesive…



  • I am attempting to compress it again now after following your posts. With 6.4 Gb of files to compress it may take a while. I’ll post again by tomorrow if it crashes again.

    I am using Maximum settings, not Ultra. The machine I am using is a P4 3.2 ghz HT with 2 Gb pc3200 RAM, Abit IC7-G Mobo, Windows XP SP2, and Radeon 9800XT 256mb.

    edit I am also using 2 200gb drives, with ~95Gb free space on each.


  • conexware

    are you compressing it via shell extensions or via main PowerArchiver window?

    thanks,



  • I have tried both, same results.

    So far I am at 57% and no crash.

    BTW thanks for the name fix :o



  • Seems to have worked, I’ll let you know if it happens again


  • conexware

    just to confirm - reboot has worked?

    thanks,



  • Okay I was able to compress the entire directory with no errors. However, I am now having another problem. While trying to convert(using the ‘convert’ shell ext) 460+ zip files (all contain pdf’s, each zip is between 5k and 200 Mb in size) it crashes about every 20-50 files during compression with the same type of error I was having with the large directory compression.
    I am using the 9.62 module you pointed me to, and a reboot has not helped this problem.

    Error signature
    AppName: powerarc.exe AppVer: 9.6.2.3 ModName: unknown

    ModVer: 0.0.0.0 Offset: 00000000

    Let me know if you need any more info


 

2
Online

9.8k
Users

6.0k
Topics

36.6k
Posts

Copyright © 1998-2018 ConeXware, Inc.
All rights reserved. Privacy Policy