Adding files to a .pae archive



  • I have an archive which is encrypted and contains several files. From time to time, I wish to add files (plain pdfs) and delete others from the .pae file.
    I open the file with the password, which is OK (the archive is opened in a temporary folder), and add the file. This appears to go OK, and I am asked if I want to update the encrypted file (Yes). However, when I go back to the encrypted archive, the file has NOT been added.

    This also seems to happen when I wish to delete files from the encrypt i.e. they are still there!

    O/S is Win XP Pro.


  • conexware

    what compression format is used?



  • Zip, normal compression, Rijndael aes 256 bit, no other encryption options selected


  • conexware

    seems to work here… few questions:

    • what version are you using?
    • are you using password manager?

    thanks,



  • PA 9.62.03, and not using Password Manager.

    I have just had another trial and the problem is still there.

    If the decrypted archive is output to a temporary folder, would that be a problem?



  • The encrypted pae file is contained within another archive file (plain old zip), which is NOT in My Documents, but in a subfolder of Documents and Settings.

    If I open the containing zip and extract the pae to my normal MY Documents/Archives directory, I seem able (after a brief test) to work on it correctly i.e. the problems I mentioned in the first place don’t occur.

    Next I will extract the pae file to the D & S subfolder and see if it works OK there. If it does, then the problem may be connected to decrypting an archive from within and unencrypted zip archive. If it doesn’t then the problem may perhaps be something to do with the directory structures and where things are.

    Will post back directly I have done this.


  • conexware

    ah, so you are working on pae file inside of an zip file?



  • Correct. I am working on the pae file directly within the zip i.e. opening zip, selecting and opening pae file from there, adding files, closing pae.

    I have tried this in a different manner. I have opened my zip, and extracted the pae file to the same (non My Documents) directory, and then worked on it from there (the pae sits alongside its container zip file).

    This seems to work, but not without oddities. If I add a file, I then close the pae and am then asked for the password. This is refused, and then I get the pae showing the file as
    filename.zip+ (i.e. the pae content), which I can then open with the password.

    It would seem that working on a pae nested in a zip is not correct.

    I am also working with “reuse PA windows” enabled, so I don’t get multiple occurrences of PA running. Perhaps this inhibits what is effectively the use of 2 PA files (zip and pae) at the same time?


  • conexware

    hm, I dont think we ever tested pae inside of zip. Have to do that.

    Why are you adding pae file to the zip file? Is there any specific reason to do that?

    As to the oddity - it is normal behaviour. You change pae file, it asks you for the password to update the file. If you do not give the password, it will not re-open the pae file.



  • I find that it is useful sometimes to work with “container files” (DEC VAX VMS style) to hold all data in one place. This allows me to effectively ignore anything else in that directory or folder, as the important stuff sits in the container zip.

    The concept is pretty much the same as ordinary files within an archive; where if you want to, you can open, for example, a pdf or document with the appropriate application, do things to it and save the altered file back to the archive.

    The difference in this case is that there is a third level i.e. zip file holding encrypted (pae) zips, in turn containing other application files some of which may themselves be further encrypted.

    I realise of course that there is no compression advantage between the “container” zip and the pae’s within - it’s only a file management strategy.

    I take your point about the other zip behaviour I mentioned.


 

4
Online

9.8k
Users

6.0k
Topics

36.8k
Posts