Delete files after executing command line



  • Not sure if this is a bug or not but everytime I create a sfx and specify an application to run after extraction and then select the option to ‘delete files after executing command line’, it launches my application but it never deletes the extracted files once I exit the app launched after extraction? Is there a reason why this doesn’t work? Using version 9.62.03

    Thanks


  • conexware

    as much as I remember, it has something to do with file that you are executing. What kind of file are you executing?



  • I’m executing an exe file that was extracted from the sfx.
    What I want it to do (and this is what I was expecting it to do based on the option description ‘delete files after command line’) is after the sfx extracts the files…I execute an exe that was part of the files extracted and then once that exe has exited, the extracted files are deleted. Am I misinterpreting what that option does?


  • conexware

    @haps:

    I’m executing an exe file that was extracted from the sfx.
    What I want it to do (and this is what I was expecting it to do based on the option description ‘delete files after command line’) is after the sfx extracts the files…I execute an exe that was part of the files extracted and then once that exe has exited, the extracted files are deleted. Am I misinterpreting what that option does?

    yes, that is what it should do. We did find in past that due to reasons of not being able to track certain exe’s, SFX would not delete anything.

    You could upload that SFX to an server and send us an link to check it out via support form at the top of the page.

    thanks,


 

3
Online

9.8k
Users

6.0k
Topics

36.6k
Posts

Copyright © 1998-2018 ConeXware, Inc.
All rights reserved. Privacy Policy