BUG: PA 9.60.09 ignores Compression Profiles



  • PA ignores the settings in Compression Profiles

    1. Start PA
    2. Go to Options -> Configuration… -> Compression Profiles, and change the compression for any format of interest. Click OK and close PA
    3. Right-click a file or folder and select “Compress With Options…“
    4. Choose the archive format for which you changed the compression.
    5. Notice that “Profile:” indicates ____” Default” and the “Compression:” setting is wrong.

    I found this out when I was compressing an archive with 7z, with what I thought was a reasonable compression setting, only to discover that PA was sucking over 170 MB and my system was swapping badly.

    Edit: Regarding the memory usage alone, even when I manually set it to “Maximum (slowest)”, PA still sucks over 195 MB! 😞



  • @welhaux:

    PA ignores the settings in Compression Profiles

    2. Go to Options -> Configuration… -> Compression Profiles, and change the compression for any format of interest. Click OK and close PA
    3. Right-click a file or folder and select “Compress With Options…”

    Unless you have already created a new profile, then the only existing profiles are "ShellExt:"
    These profiles are used by the Win Explorer shell options and NOT by PA “New Archive” or “Compress with options…”

    If you do create a new profile, then you must select this in the Profile “drop down” which activates when you select the format (the Default is selected automatically).


  • conexware

    yep. Shell extension default profiles are profiles that are used when you use compress to filename.zip.

    Once you enter Options, then different default profile is used (which is latest used settings unless you create special profile).

    As to the memory usage. Select Normal for less memory. Large dictionaries is how 7zip compresses better than other formats…



  • Oh. Thanks for the correction! 🆒


  • conexware

    np, closing the thread.


Locked
 

5
Online

9.8k
Users

6.0k
Topics

36.8k
Posts