Could not upgrade to PA 9.6 beta 1 (9.6.0.8)



  • I upgraded from my previously 9.51
    rebooted, and that’s what happens when I call the program (I’m Italian, so errors are in my language):

    and then

    I’m now going to uninstall it then reinstall the last beta, to see what happens.

    I’m writing here because it’s really the 1st time I’ve experienced a problem when upgrading PA 😞



  • I saw the second error (interface not registered) after updating a PA 9.51 to PA 9.60b1 - but I had not rebooted.

    After rebooting, PA 9.60b1 is working fine.



  • @mwb1100:

    I saw the second error (interface not registered) after updating a PA 9.51 to PA 9.60b1 - but I had not rebooted.

    After rebooting, PA 9.60b1 is working fine.

    That seems to be a problem with the dll which implements the Explorer (shell) options - it is replaced and a reboot is needed.

    Not sure about “manuangi’s” first problem. Was the previous version (9.51) using a different skin (non-default) perhaps?

    As a “general rule” I would not advise << upgrading >> to a ‘beta’ version of any software. I always do a clean install (uninstall previous/reboot/install ‘beta’).

    Still feedback that there was a problem is useful.


  • conexware

    definetly an old skin. We have to be able to handle that better.

    thanks!


  • conexware

    @mwb1100:

    I saw the second error (interface not registered) after updating a PA 9.51 to PA 9.60b1 - but I had not rebooted.

    After rebooting, PA 9.60b1 is working fine.

    what OS are you using?



  • @spwolf:

    definetly an old skin. We have to be able to handle that better.

    thanks!

    yea, I was using the “bunnies” skin that I love so much 🙂

    so, spwolf, what’s your advice about how to proceed?

    thank you


  • conexware

    try deleting the skin that you were using? If not, you can uninstall it and install it again, which will delete the registry keys…

    thanks!

    p.s. what OS?



  • @spwolf:

    try deleting the skin that you were using? If not, you can uninstall it and install it again, which will delete the registry keys…

    thanks!

    ok…but I really loved the bunny-skin 😞

    p.s. what OS?

    WinXP SP1


  • conexware

    I think restart is the most important step here, so please restart your computer when installation tells you so!

    thanks,



  • I always did, if you read my previous posts.

    anyway, uninstalling/reinstalling PA did the trick

    can I apply my bunny skin again, or you think there could be problems?


  • conexware

    skinning engine is completly new, only toolbars will work (complete skin wont)…



  • @spwolf:

    what OS are you using?

    WinXP SP2.

    Note that I did not consider the error message I saw to be a bug - the update told me that I had to reboot, but I generally ignore those messages unless I run into problems because reboots are often not really necessary for many products - the install process is just being overly conservative.

    However, if you can workaround the need to reboot, obviously that would be a plus!


  • conexware

    @mwb1100:

    WinXP SP2.

    Note that I did not consider the error message I saw to be a bug - the update told me that I had to reboot, but I generally ignore those messages unless I run into problems because reboots are often not really necessary for many products - the install process is just being overly conservative.

    However, if you can workaround the need to reboot, obviously that would be a plus!

    Did you install PA in same folder as before or in new folder? Did you keep old version installed?

    I noticed one case where installer would not register skin dlls until reboot, but in that case PA would have tell you that you cant install until reboot and you would have to delete your registry key for pending renames, which is probably not what you did?

    thanks,



  • @spwolf:

    Did you install PA in same folder as before or in new folder? Did you keep old version installed?

    I noticed one case where installer would not register skin dlls until reboot, but in that case PA would have tell you that you cant install until reboot and you would have to delete your registry key for pending renames, which is probably not what you did?

    thanks,

    I just installed the beta over the existing install (I’m wreckless sometimes). No problems - it told me to reboot, but I didn’t (wreckless…) and it gave the interface registration error when I tried to start PA. After a reboot I tried again, and everything is working fine.



  • @manuangi:

    … can I apply my bunny skin again, or you think there could be problems?

    Not sure what “bunny skin” is.
    If you mean “Rabbit XP” then that is a toolbar and not a skin, so…
    @spwolf:

    skinning engine is completly new, only toolbars will work (complete skin wont)…

    Maybe? {Can’t try it myself at moment sorry… }



  • @TBGBe:

    Not sure what “bunny skin” is.
    If you mean “Rabbit XP” then that is a toolbar and not a skin, so…

    skinning engine is completly new, only toolbars will work (complete skin wont)…

    Nope.
    Doesn’t work - or at least I cannot see how to apply the “old” toolbar button “skins”. 😕


  • conexware

    Config> Skins & Toolbar :-).



  • @spwolf:

    Config> Skins & Toolbar :-).

    :o I was trying via
    Options - Skins …
    Skins(right click) …
    Select Buttons …

    Missed the Config settings :o
    OK it does work.


 

4
Online

9.8k
Users

6.0k
Topics

36.8k
Posts