Cannot extract from a GZ file



  • Seems that PowerArchiver 9.00.33 cannot extract from http://cermics.enpc.fr/theses/94/these-xiaolan-zhang.ps.gz

    Though GSView 4.6 can directly open a ps.gz file, it’s still inconvenient if one wants to jump forward or backward inside the ps.gz document.


  • conexware

    what exactly doesnt work? I tried extracting and works fine…

    thanks



  • The exact error message is

    " is not a valid integer value.

    This message leads by one double quote and doesn’t contain any specific number inside. After dismissing the error message box, the status bar remains displaying “Reading folder …” and the PA window stops response and will produce a sound when you click inside it.

    My PA 9.00.33 is an unregistered version. I store the above mentioned file in “My Documents\My Downloads” (a path containing spaces). My OS is XP SP1 with all the latest patches applied.

    Seems strange though. It might not be a generic problem for all.


  • conexware

    Hi,

    Please check this version and see if it helps:
    http://www.powerarchiver.com/test/powarc90035.exe

    thanks,



  • Downloaded that file and tried with 9.00.35 (Win2k).

    Explorer Shell “Extract to these-xiaolan-zhang.ps”

    • creates the directory but no files are extracted and no errors reported.

    Double Click in explorer (launching PA) give the errors described by jacqueslichn.
    See GZ Error / GZ Reading.

    Note: When clicking the OK button on the error dialogue, PA hangs - no response to mouse/keyboard (just system beeps) and had to be closed with Task Manager.

    However, the cause of the error was an incorrect download (for some reason it downloaded as 1.8MB the first time instead of 623kB).
    After re-downloading the file - no errors occurred.

    The error message / handling could be improved :p



  • Note to jacqueslichn

    The download error is caused by incorrect coding of that Webpage/Server.
    You may wish to inform the Webmaster of the school (I don’t speak/write French).

    He’d need to change things so the files (that ends in *.gz) are identified as the type for a gzipped file.



  • @TBGBe:

    The error message / handling could be improved

    Tell me about it …

    I also downloaded the file, can extract it from context menu, but if I doubleclick it and drag the file from the PA window into explorer window ( or the desktop ), nothing happens.

    I use Win2003-enterprise.

    Does dragging files from PA into explorer work for others at all ?
    I just reported a drag-problem for tar.bz2 files …



  • Thanks to all, you’re so nice. I use Opera 7.54. It could be that IE can handle the MIME correctly, while Opera still has some flaw.



  • MS noticed that 88% of webmaster are clueless and can’t set up their web servers for correct MIME handling, so they built into IE extra code to try and guess the correct MIME type ( because the www server send a wrong one ).

    It is a web site configuration problem. -> talk to the webmaster


  • conexware

    I corrected the bug you had with corrupted archive - now it will display error message saying that archive is corrupt when opening .gz file directly from PowerArchiver.

    Also the bug with drag&drop-ing to Windows Explorer will be fixed in next release!



  • @jacqueslichn:

    Thanks to all, you’re so nice. I use Opera 7.54. It could be that IE can handle the MIME correctly, while Opera still has some flaw.

    Actually, the problem is the exact opposite.
    Opera does what the Server is requesting should be done with the file.
    I.E. does not!

    The fact that, in this case, the Server has an error and thus I.E. ignoring it ends up with the “intended” outcome is accidental.

    However, that has nothing to do with PA and is not relevant to this forum.



  • Judging from my overall experience with Opera, I think it would be appropriate to describe IE as a monolithic browser, though Opera is still slightly buggy with its page rendering algorithm (It cannot render mail.yahoo.com correctly). Of course this post is not related to PA at all. Just a tip. :rolleyes:


 

1
Online

9.8k
Users

6.0k
Topics

36.6k
Posts

Copyright © 1998-2018 ConeXware, Inc.
All rights reserved. Privacy Policy