Upper relative pathname not included



  • PA 9.51.01

    Hi,

    I have often used PA in the past, to compress files for websites, and have a path setup on my computer as follows:

    public_html
    –-modules
    -----somemodulename

    I create the archive (tar/gz), then press ADD, and have always selected the path ‘public_html’, and PA has always included the path ‘public_html’ in the pathname in the archive, which then makes it very easy to upload and unzip on the website.

    I have always used ‘store relative paths’ in the ‘add’ function, but I have tried several times, and PA refuses to include the folder name I have selected on my computer (public_html). I even created a small file in this path, but PA will not include it.

    I did not have this problem with the earlier release of PA.

    This has made a ‘mess’ of uploading the archive to the website, previously the upload would find the path ‘public_html’ in the archive, and all files would be unzipped and placed in the correct paths. They are now in the wrong paths.

    This would seem to be a bug in the latest version of PA.

    Peter



  • I had to check/tick this option in the configuration, to get it to work:

    Miscell | General | use normal relative path

    I would have thought that option would not have been changed with the new version installation, unless it is a new option, and now required to get the top level pathname in an archive ??

    Anyway, the pathname ‘public_html’ is in the archive pathname now, for all files.

    Peter


 

4
Online

9.8k
Users

6.0k
Topics

36.8k
Posts