PA and Windows Vista



  • I successfully installed PA2006 and tried to run it, and got an error message “Runtime error 216 at 0040428E”. Does anyone know what’s the problem 🆒 !?


  • conexware

    @markovuksanovic:

    I successfully installed PA2006 and tried to run it, and got an error message “Runtime error 216 at 0040428E”. Does anyone know what’s the problem 🆒 !?

    who really knows :-). Check with beta 2 and see if that works better.


  • conexware

    hi,

    did you check with beta 2 and did it work?

    thanks,


  • conexware

    if anyone has more info on Vista and latest beta, it would be appreciated…

    thanks,



  • Okay, I had to test my own software on Vista Beta 1 anyway, so I gave PowerArchiver 2006 Beta 4 a quick spin.

    The main window and nag screen is shown, but then Windows immediatelly says the application has crashed. The event log shows that there was an exception code c0000005 at address 0x01caff98.

    I will probably revert the hard drive I installed Vista on to its original purpose in a few days (my software seems to work fine 🙂 ), but until then I can do further tests if needed.


  • conexware

    @marci:

    Okay, I had to test my own software on Vista Beta 1 anyway, so I gave PowerArchiver 2006 Beta 4 a quick spin.

    The main window and nag screen is shown, but then Windows immediatelly says the application has crashed. The event log shows that there was an exception code c0000005 at address 0x01caff98.

    I will probably revert the hard drive I installed Vista on to its original purpose in a few days (my software seems to work fine 🙂 ), but until then I can do further tests if needed.

    please check with b5 and let us know… thanks



  • Unfortunately same problem, just different crash: “Faulting application POWERARC.EXE, version 9.5.0.24, time stamp 2a425e19, faulting module ntdll.dll, version 6.0.5112.0, time stamp 42df2d46, exception code 80000003, fault offset 0x0000ea48.”

    A crash within ntdll probably isn’t too descriptive, especially without symbols, so I tried to get a stack dump, but when running under a debugger a completely different crash within PowerArchiver occured. I suppose you might employ some anti-debugging tricks?

    Interestingly only the offending thread is halted, the rest of PowerArchiver sort of continues to work until the user chooses “Close program” in the fault dialog. While playing around I noticed several problems in the app (file dialog not opening, icons not showing), but I guess they might be related to the crash and are thus probably not worth investigating at this time.


  • conexware

    thanks!


 

7
Online

9.8k
Users

6.0k
Topics

36.8k
Posts