Please Notice: For fastest support from PowerArchiver team, contact us via our Support page

Encrypt filenames


  • Banned

    Two related requests:

    1. I would like the option to encrypt filenames in any format that has such an option.
    2. In those formats, I would like the option to create a profile where that option is chosen.

    Why these?

    Once I could encrypt filenames in 7z (could have been zipx). I no longer see that option in the latest build (though I could be overlooking it).

    Rar5 does have that option (available when manually creating a RAR archive using “compress to” option within PA), However, that option is not (as far as I can see) one users can choose when creating a new RAR profile.


  • conexware

    Good point about RAR.

    As to 7zip - isnt it enabled when you select AES 256 bit encryption? Thats how it should work.

    With ZIP, thats patented, and we cant use it.


  • Banned

    . . . the option is greyed out even in 7z with 256 (that’s where I thought it was in earlier options). See image

    It is not an option at all if I try to build a 7z encrypted profile (unless I am missing something).
    attachment_p_33620_0_7z-with-aes.png


  • conexware

    ah, advanced add screen probably, does the same happen when you use “normal” add screen?


  • Banned

    I thought I tried it every way I know. I start with the shell, since that is what I usually use. Then I thought I tried the add screen from within PA.

    However, even if there is some screen that has this option, there are others that do not. And none of the options to build a compression profile include it.

    Now perhaps there is a screen (if so, I would like to know where). And perhaps there is a reason why the option cannot be on the other screens. That is something you all must decide. I was just suggesting that were it doable, these would all be nice options to have.


  • conexware

    it seems to be something with the use of profiles, when profiles are not used, I can select encrypt filenames in both shell and add window. I will get Mili to test it out and write it up.

    thanks!


  • Banned

    Same is true with the other add window (see image).

    I thought it would be nice to:
    a) have the options in add windows, and
    b) have the option to make it a feature in some user profiles.

    Perhaps, though, none of this is doable.

    I just saw your note (I thought mine disappeared, so I did a partial repeat.
    So perhaps the option doesn’t like the user to have profiles. Doesn’t seem infeasible at all.
    attachment_p_33624_0_other-add-window.png


  • conexware

    yeah, should be working next release lets hope


  • Banned

    That would be great. Thanks.


  • conexware

    thanks Socrates, seems to happen when you use custom profiles with Encryption enabled, then the Encrypt Filenames checkbox is not available as it should.
    If you choose Disabled in the Encryption field and then AES encryption again, it will show up. Logged in for fixing.
    Also logging in to add the Encrypt Filenames option to 7z and RAR formats in the compression profiles section.

    thanks again


  • Banned

    Thanks. for discovering the source . . . and logging it in.

    Best,

    Hugh


  • Banned

    Similar thread . . . but not entirely.

    I have been adding files to existing archives using user profiles without a hitch (other than the missing option).

    Today I tried to create an archive using an existing profile. The options in the add window didn’t match the profile settings. Then the truly odd thing. It made the motions of creating an archive . . . except it wasn’t there.

    But then I choose the Compress to option. A filename I tried to create was listed.

    I think there are more kinks in the profiles.

    I may try to delete and remake a couple of then and see how they fare. Perhaps the settings were lost in the new installation.

    BTW, it happened only with zipx. It happened even after I deleted and recreated the profile.

    There is no comparable problem with 7z with encryption.


  • conexware

    if you are using Windows 7 or 8 with libraries, i noticed that on my computer they quite often dont update properly (libraries)… so file might be there (as noticed when you type its name save as window, if it is autocompleted, means file is there) but not shown since library listing did not update.

    Try going directly to that folder so for instance:
    C:\Users\username\Downloads

    or whatever that folder was.


  • Banned

    I have seen this phenomenon. But not here. I checked 2-3 different ways. It wasn’t really there.

    Very odd.

    Thanks, though, for the suggestion.


  • conexware

    maybe it was due to some option then?


  • Banned

    Maybe. I just think that it didn’t really actually created the archive. But it is hard to be certain. ONLY on zipx with profiles.


  • conexware

    Socrates, does this now work in 15.02.01? Thanks!


  • Banned

    It is there and it’s checkable. I assume it works, but haven’t tried it.

    thanks!


  • conexware

    we also added encrypt filenames option to profiles… thanks for the report!


  • Banned

    noticed it early. It was one of the main positive changes to which I was referring in the earlier post.

    Thanks.


Log in to reply
 

Looks like your connection to PowerArchiver Forums was lost, please wait while we try to reconnect.