FTP Option does not work



  • Task is quite simple.

    Compress folder and copy to ftp.

    I can make a profile but I can’t test my settings. Would be nice if there would be a test button.

    Ftp is accessible from commandline and works as expected.

    PA2009 runs say that backup was successfully. No file in ftp folder.

    Any ideas?


  • conexware

    check default folder in ftp profile… that could be the issue…



  • Already checked several times.

    Did some testing with the backup feature… A COMPLETE DESASTER…!!!

    No scheduled backup was run. So no backups at all.

    But a small light at the end of the tunnel. When I run a backup of a dir like about 200MB it seems to work. Even the ftp does work then. But when I try to make a backup of dirs having GBs it doesn’t even start.

    Hope this is a RC issue… This was the reason I bought it for. Doing backups from my servers and copy away via ftp.

    Regards, Alex



  • Did some more testing…

    ok… Here we go. When I use the zip format instead of 7zip it does work. Didn’t try scheduled backup yet, but the backup now to ftp does work.

    On another server with exactly the same ftp settings i get this in the log file…

    Backup to D:\Temp_PA468319321\kpi01-23-09-2008.zip started at 23.09.2008 08:31:27
    Backup Done. D:\Temp_PA468319321\kpi01-23-09-2008.zip
    Uploading D:\Temp_PA468319321\kpi01-23-09-2008.zip
    connecting to ritstor
    220 Gene6 FTP Server v3.10.0 (Build 2) ready…

    230 User ritbackup logged in.

    setting directory
    Uploading kpi01-23-09-2008.zip
    Error uploading file. Check if destination path exists and you have write access.
    Also check passive mode if you are behind NAT or firewall.
    Backup Done. — 23.09.2008 08:31:57

    Any ideas… The same ftp profile on another server does work. The file shall be written just to the ftp root dir.

    Regards, Alex



  • Is there any file limit in zip or PA?

    The most important folder has 106000 files and 37 GB.

    When I try to backup that folder, PA hangs and the log is empty…


  • conexware

    as I said before, check destination folder in ftp settings… it is ~, remove that completly and try again.

    There is no file limit in Zip/7zip, but backing up 37 GB of files will take huge amount of time, both first to the disk and then to the ftp.

    I dont think PA hangs, it it building file list for 106000 files… Just leave it on.



  • ok… Doing tests now… Will tell you…

    Anyway… Thank you very much for the support…



  • Backups didn’t even start. How can I check if the scheduler is working? Is the scheduler just working if I am logged in? As soon as I logged in PA started.

    I also have another problem. PA stops with an error message of no space left or file access forbidden. There is more than enough space left on the device. I also tried to use another disk. Same issue here.



  • Error writing to a file.

    Possible reasons: Disk full or no write permissions.
    Please check if you have permissions to write to this folder.

    Vista users:
    In Microsoft Vista, writing to certain folders is not allowed (i.e. C:\Program Files).
    You will need to start PowerArchiver as Administrator. If you are extracting files you
    can use drag and drop from PowerArchiver main interface to extract files to that folder.
    Uploading D:\Temp_PA1653574904\kpi01-24-09-2008.7z

    There is still 300GB left an 😨



  • This might help with the scheduler thing…

    Task Scheduler failed to start “\blabla.pbs” task for user “blablub\Administrator”. Additional Data: Error Value: 2147943645.


  • conexware

    @steiale:

    Error writing to a file.

    Possible reasons: Disk full or no write permissions.
    Please check if you have permissions to write to this folder.

    Vista users:
    In Microsoft Vista, writing to certain folders is not allowed (i.e. C:\Program Files).
    You will need to start PowerArchiver as Administrator. If you are extracting files you
    can use drag and drop from PowerArchiver main interface to extract files to that folder.
    Uploading D:\Temp_PA1653574904\kpi01-24-09-2008.7z

    There is still 300GB left an 😨

    try using zip instead of 7zip…

    as to the task scheduler - edit the task, and make sure your username and password is entered in the task scheduler properly - that is the only way task will start without you logged in (i assume that is the issue)…


  • conexware

    (or uncheck optimized from 7z settings).


  • conexware

    is this one of the time backup and later you will be using incremental backups for only changed files?



  • I always want to use full backups. Have bad experiances with incremental backups.
    In a first step I used zip as suggested… I will see tomorrow.

    I also set the password as you mentioned.

    Thank you!



  • Backups did partly work… I will do some further testing…



  • @spwolf:

    try using zip instead of 7zip…

    That didn’t solve the issue. Any other ideas?


  • conexware

    @steiale:

    That didn’t solve the issue. Any other ideas?

    well what was the issue?



  • Sorry…

    Error writing to a file.

    Possible reasons: Disk full or no write permissions.
    Please check if you have permissions to write to this folder.

    Vista users:
    In Microsoft Vista, writing to certain folders is not allowed (i.e. C:\Program Files).
    You will need to start PowerArchiver as Administrator. If you are extracting files you
    can use drag and drop from PowerArchiver main interface to extract files to that folder.
    Uploading D:\Temp_PA1653574904\kpi01-24-09-2008.7z

    There is still 300GB left an 😨


  • conexware

    you are still trying with 7z :).

    Download final release from download page or via Web Update.

    If you want to use 7zip, try using Normal setting which takes up a lot less memory. Try with Zip as well.

    How many files/folders are you compressing in total?



  • This was what I was trying to say. i used zip and it still didn’t work. Even with final version…

    Not so much… Something like 7GB, 8 Folders… I always use the normal setting… Never tried full or incremental.


  • conexware

    @steiale:

    This was what I was trying to say. i used zip and it still didn’t work. Even with final version…

    Not so much… Something like 7GB, 8 Folders… I always use the normal setting… Never tried full or incremental.

    above error is 7zip error not zip.

    Check compression - make sure it is Normal, not Ultra/Max (not backup type, compression strenght).


  • conexware

    you can send us that pbs file at support at conexware.com so we can take an look, but please download final version of PA before so we can make sure this has not been address already… thanks!



  • @spwolf:

    you can send us that pbs file at support at conexware.com so we can take an look, but please download final version of PA before so we can make sure this has not been address already… thanks!

    Like I said… It is the final version…

    ok… but I will do some final test. I just right clicked and said create 7zip. At the same time I do right click an create zip.

    We’ll see how far I come…

    If this doesnt work I will send you the pbs file.


  • conexware

    ok, what compression are you using with right click 7z? Try using Normal instead of Ultra…



  • ok… Here we go…

    The 7zip and zip with right click worked. So I checked which settings the right click options have. Changed the pbs file to these settings and starting the pbs worked finally…!!

    The only thing I changed was putting the 7zip compression level fom utra to maximum. Then it worked and uploaded the file to the ftp server.

    Now the scheduler has to work and I am happy…



  • Here we go again… 🙂

    After the scheduled backups finish I see in the processes list that the PA.exes are still open. So I guess that after successful backup they won’t be closed…

    And I still have on a Windows 2003 Server the problem that the task is not running. Only when I log in. But I gave the scheduled task a user and password. Any ideas?


  • conexware

    @steiale:

    Here we go again… 🙂

    After the scheduled backups finish I see in the processes list that the PA.exes are still open. So I guess that after successful backup they won’t be closed…

    And I still have on a Windows 2003 Server the problem that the task is not running. Only when I log in. But I gave the scheduled task a user and password. Any ideas?

    if task is nor running unless you login, you need to check in windows scheduler what the problem is - you can check directly in scheduler. Common problem there is that correct login/pass was not provided so schedule cant login.

    as to the pa.exe staying in the background - send us your pbs and we will try it out.

    thanks,



  • I sent you the file.

    I checked several times the scheduler… Still not knowing where the problem is… I will keep on searching.


  • conexware

    did you check in Computer Managment> Task Scheduler? (or whatever it is called in Win2003)



  • Yes I did and in the properties “run only if logged on” is not checked. No idea why this is not working. I gave the task also the right user and pass…



  • Cant send you the pbs file. Its forbidden by our mailserver. Any other ideas…



  • I tried to send you the text output… Forbidden either… But I think I found the error.
    The alert thing backup done was enabled… I disabled it… We’ll see tomorrow…


  • conexware

    zip it and send it.

    Alert has nothing to do with task scheduler - it is problem with Win2003 task scheduler, as long as task is entered there, it has to run (nothing to do with PA itself anymore).



  • ok… Maybe I should write things a bit clearer.

    One problem is that the task is not running in scheduler which is for sure a scheduler thing. Other tasks in scheduler do run perfectly on the same machine, so I thought it is maybe a small bug in writing fom PA to the scheduler in Win 2003.
    Now behaviour is even stranger. The scheduled backup is stated running in the scheduler but no PA is started… This makes me going mad… 🙂

    The other problem was that PA is not closing after scheduled jobs. I found the error as I wrote above. You have to uncheck the alert. Maybe you should da this by default when having schedules tasks. If alert “backup done” is enabled then PA doen’t close after backup and stays open and in memory of course then.

    Regards, Alex


  • conexware

    aha, i understand better now - problem is that we dont know if schedule is done when user is not logged in or when they are logged in - meaning, if we disabled it, many people will complain for not getting the done msg (it happened before).

    However we can leave an timer - that will work? Auto disable/ok after 10 minutes for example?



  • Perfect!!!

    🙂



  • ok… everything seems to work now. I made a complete new pbs and scheduler job. This one runs now… No Idea why because it is exactly the same as the one one that didn’t run.

    Thanks for the great support!!


Log in to reply
 

  • 7
  • 10
  • 5
  • 28
  • 4
  • 35
  • 4
  • 8