7-zip issues



  • Hi,

    1. Context menu: Compress to 7-zip + Options…

    The Ultra compression seems that does NOT work, because I can only get best compression using the context menu: Compress to “XXXXXFile.7z”

    1. Compression profiles

    When a 7-zip profile is configured the Ulta Compression is not shown in combo.

    Best regards!


  • conexware

    Hi,

    thanks for info on profiles. As to compression in shell extensions, in works here - keep in mind that for some files, you wont be able to see the difference between different compression methods…

    thanks,



  • Hello again,

    I have a folder with a total of 1.54MB of files and sub-folders (with more files).

    1. Right click the folder and select Compress to “folder.7z” I got a file of 289 KB;

    2. Right click the folder and select Compress to 7-zip + Options… and select Ultra compression I got a file of 434 KB;

    3. Right click the folder and select Compress to 7-zip + Options… and select Maximum compression I got a file of 434 KB too.

    So, from shell (+Options) Ultra and Maximum produce the same file compression.

    I have tested it several times…


  • conexware

    do you have compression profiles set, or anything other than default installation? Did you reboot your computer after installation of 9.00?

    thanks,



  • Yes, I re-started it.

    Yes, I had a profile, but I deleted.

    I made another test with same results…

    I have 7-zip installed, but I don’t think this is the problem…

    I will make more tests and I’ll get back here to post…

    Thank you.


  • conexware

    The profile problem will be fixed in next release.

    One more information. Compress to file.7z now uses Ultra compression + Solid, so to get same results via +Options feature you must turn on also Solid compression.

    I will do some small change for next version, so Compress to file.7z uses Maximum + Solid instead of Ultra + Solid (since Ultra can cause memory problems).



  • After check “Solid” now it’s working fine.

    I have tested (just one test!) Maximum+Solid and I got the same result as Ultra+Solid, however Maximum+Solid was faster.

    Thanks.


  • conexware

    Sure, ultra can be better only on very big sets of files (with solid option) or on very big files (without solid option). The difference is in dictionary size and when some dictionary size is enought for some files,then there is no difference in ratio. But maximum is always faster and uses less memory.



  • @ivan:

    I will do some small change for next version, so Compress to file.7z uses Maximum + Solid instead of Ultra + Solid (since Ultra can cause memory problems).

    Please don’t!
    I (and many others I guess) like it as it is…with the ultra option set by default!



  • Then again, on my W98 ancient laptop machine I can’t use Ultra (only 64M ram) 😃

    All the Explorer shell direct (compress to NN) options should really have dedicated configuration options.



  • yea, but I guess nowadays all PCs have at least 256MB of RAM…and most of them run WinXP…it’s obvious that devs spend most of their efforts on those kind of system…(I’ve got 2GB of RAM 😃 )

    anyway…What do you mean by “All the Explorer shell direct (compress to NN) options should really have dedicated configuration options”?
    Can’t you create your own profile via Configuration -> CompressionProfiles?



  • Manuangi
    I … like it as it is…with the ultra option set by default!

    create your own profile via Configuration -> CompressionProfiles?

    :rolleyes: Couldn’t you ? :rolleyes:

    Seriously, thanks for the reminder.
    Played with profiles for a few days then completely forgot about them 😕


  • conexware

    @TBGBe:

    Then again, on my W98 ancient laptop machine I can’t use Ultra (only 64M ram) 😃

    All the Explorer shell direct (compress to NN) options should really have dedicated configuration options.

    problem with that would be inexperienced users changing it and then thinking its PA’s fault. We already have fair share of people asking us how come PA doesnt compress mp3’s or jpg’s…

    thanks,



  • That’s OK - I can work with profiles (once the BZip2 query is sorted out).

    P.S.

    … how come PA doesnt compress … jpg’s …

    Well, when I checked last, it does (a little bit) - depends on format 😃

    Graphic jpegs (digital camera) - 10 Files Total 12,600,516 bytes
    -> cab 12,564,597
    -> bh 12,588,570
    -> zip 12,589,310
    -> lzh 12,593,241

    Whereas rar & ace both increased the total size (real Byte size, ignoring Disk usage).


 

2
Online

9.8k
Users

6.0k
Topics

36.9k
Posts